How to get rid of echo in recordings?

Maihem

New Member
Hey, I've got a question about removing an echo from my recordings.

When recording voice, I get some echoes here and there while talking. I've tried multiple mics and headsets, but the problem remains (probably because the room's acoustics aren't that great).

I've got basic knowledge in editing out noise in Audacity, but the problem for me is isolating the echo. This makes it hard to edit it out, since the noise removal also picks up part of the commentary. Does anyone know of a way to isolate just the echo?

Thanks in advance!
 

In'Victus

New Member
I'm using the Nessie Microphone by Blue Microphones.
Have had the same problem with other mics before, except they were even worse.
if its an actual microphone like the yeti you probably need a filter of some sort, to mask the microphones audio thingy, idk too much about audio stuff but thatll probably fix most if not all of it
 

risktwo

Member
If you tried different mics then its probably the software? Have you tried a different program? I'm not familiar with audacity, but in final cut pro there are audio options to reduce background noises and other annoying sounds. It does a decent job.
 
Top